[EasyLinux-Ubuntu] bash: [: !=: Einstelliger (unärer) Operator erwartet.

Heinz-Stefan Neumeyer hsn.debian_user at gmx.net
Son Jun 6 02:30:15 CEST 2010


Hallo an alle Mitleser,

nach einem beinahe-Festplatten-Crash habe ich heute Abend in meinen 
"Schlumper/Arbeitsrechner" eine neu einbauen müssen und neu 
installiert. Seit dem nervt die bash mich mit solcher Meldung

bash: [: !=: Einstelliger (unärer) Operator erwartet.

Die kommt bei starten eines Terminals und aber auch beim Aufruf von 
Anwendungen darin, wie z.B. ssh, htop, fetchmail, mutt und diversen 
Scripten...
Diese Anwendungen lassen sich nicht mehr starten!!!

In einem Ubuntu-Forum habe ich zwar Hinweise auf ähnliche Probleme 
finden können, aber keine passende Lösung. Einstellungen für die bash 
habe ich von der alten Platte übernommen. Aber auch mit einer "sauberen" 
bashrc, kopiert aus /etc/skel habe ich das gleiche gemecker...


btw.
Ist bei mir zwar die erste (und einzige), insgesamt aber bereits die 
vierte Western-Digital-Platte, die ich dieses Jahr austauschen muß!

-- 
Gruß Stefan

"...wenn ein Hund plötzlich nach der Hand schnappt, die ihn über viele
Jahre lang gefüttert hat, dann bekommt er Prügel! Da beißt er entweder
richtig zu - oder kneift den Schwanz ein und rennt fort..."

(nach wenigen Minuten gelöschter Kommentar in einem Provider-Forum zum
Rücktritt von Horst Köhler)
-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname   : nicht verfügbar
Dateityp    : application/pgp-signature
Dateigröße  : 836 bytes
Beschreibung: Digital signature
URL         : http://www.easylinux.de/pipermail/ubuntu/attachments/20100606/7d1235a4/attachment.pgp